Korg Electribe 2 Downgrade from 1.18

Dowgrade Korg Electribe from 1.18 to 1.10

UPDATE: Added a windows compatible version

Some of you on my mailing list and youtube users, contacted me about if they can test the hack on their upgraded electribes (1.17 and 1.18, the current official firmwares from korg). At first I said no, assuming that the hack will not work as downgrade, but Greg, contact me and his research went forward and found a way to this on a french forum.

For my followers, I decided to the same as the first firmware files, and give it easy. In the next video, I’ll show how easy is to rollback using my firmware:

I created the same modified firmware file of 1.10 that acts as 1.18, allowing to roll back your electribe if already has 1.17 or 1.18.

In order to get the file, you must share this post with your friends. Notice that KORG don’t recommend this

And after this you probably want to try the HACK

Share on TumblrTweet about this on TwitterShare on FacebookShare on Google+Pin on PinterestEmail this to someone

Published by

victor

music producer, tech addict, music addict

12 thoughts on “Korg Electribe 2 Downgrade from 1.18”

  1. You can still downgrade Electribe synth from v2.02 to Victor’s modified “1.18” file !

    Hex edit the firmware file, and change location A 20 from 0112 to number bigger than 0202 (v2.02). I entered 0209, and was able to downgrade to modified “1.18” file and then apply the E2 -> E2S hack!
    I used his hacked v1.06 E2S.

    If somebody is very brave, they can try to update to a higher (v2+) Sampler firmware – it may brick the Electribe…

  2. I upgraded E2 from 1.07 to 1.17 from KORG site, and now it just can’t load. It shows Electribe logo, “Working” and after that – “Error. Unknown error”. Do you know what is the problem or how to fix it?

Leave a Reply

Your email address will not be published. Required fields are marked *